
Добрый день. Нужна помощь в паскале. Необходимо составить программу подсчёта количества нулевых
элементов в массиве А(100). Буду премного благодарен. Спасибо.

Ответы на вопрос

n=100; { размер массива }
var
a:array[1..n] of integer;
i,k:integer;
begin
{ заполняем массив случайными значениями }
Randomize;
k:=0;
Writeln('Элементы массива');
for i:=1 to n do
begin
a[i]:=Random(41)-20;
Write(a[i],' ');
if a[i]=0 then Inc(k)
end;
Writeln;
Writeln('Нулевых элементов: ',k)
end.



Добрый день! Конечно, я могу помочь вам с написанием программы на языке Паскаль для подсчёта количества нулевых элементов в массиве А(100).
Вот пример кода на Паскале, который решает вашу задачу:
```pascal program CountZeros; var A: array[1..100] of Integer; // объявляем массив А с размерностью 100 i, count: Integer; // переменные для цикла и подсчета нулевых элементов
begin count := 0; // инициализируем счетчик нулевых элементов
// заполняем массив А случайными числами от -10 до 10 Randomize; for i := 1 to 100 do A[i] := Random(21) - 10;
// подсчитываем количество нулевых элементов в массиве А for i := 1 to 100 do begin if A[i] = 0 then count := count + 1; end;
// выводим результат writeln('Количество нулевых элементов в массиве А: ', count); end. ```
В этой программе мы объявляем массив А размерностью 100 и заполняем его случайными числами от -10 до 10. Затем мы проходим по всем элементам массива и, если элемент равен нулю, увеличиваем счетчик count на единицу. В конце программы выводим результат - количество нулевых элементов в массиве А.
Надеюсь, эта программа поможет вам решить вашу задачу. Если у вас возникнут дополнительные вопросы, пожалуйста, сообщите мне.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili