Помогите написать программу паскаль, которая формирует массив, элементами которого являются цифры
заданного натурального числа.Ответы на вопрос
a: array of byte; //char?
b, d: integer;
begin
readln(b);
SetLength(a, length(IntToStr(b)));
for d := 0 to length(a) - 1 do
begin
a[d] := b mod 10;
b := b div 10;
end;
for d := 0 to (length(a) - 1) do
write(a[d], ' ');
end.
Программа на Паскале для формирования массива из цифр заданного натурального числа
Вот пример программы на языке Паскаль, которая формирует массив, элементами которого являются цифры заданного натурального числа:
```pascal program FormArray;
var num: Integer; digits: array of Integer; i: Integer;
begin Write('Введите натуральное число: '); Readln(num);
// Определяем размер массива SetLength(digits, Length(IntToStr(num)));
// Заполняем массив цифрами числа for i := 0 to Length(digits) - 1 do begin digits[i] := num mod 10; num := num div 10; end;
// Выводим массив на экран Write('Массив цифр числа: '); for i := Length(digits) - 1 downto 0 do Write(digits[i], ' ');
Readln; end. ```
Эта программа сначала запрашивает у пользователя натуральное число. Затем она определяет размер массива, который будет равен количеству цифр в числе. Затем она заполняет массив цифрами числа, начиная с последней цифры и заканчивая первой. Наконец, программа выводит массив на экран.
Пример работы программы:
``` Введите натуральное число: 12345 Массив цифр числа: 1 2 3 4 5 ```
Надеюсь, эта программа поможет вам. Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
