Вопрос задан 10.05.2019 в 01:00.
Предмет Информатика.
Спрашивает Ковалёв Максим.
Составить программу, которая запоминает массив а (1...10) случайными числами от 1 о10 затем первый
элемент меняет местами с максимальным элементомОтветы на вопрос
Отвечает Сорокина Рина.
Var
a: array [1..10] of integer;
i, max, s, x: integer;
begin
s:=1;
randomize;
for i := 1 to 10 do
begin
a[i] := random(10) + 1
end;
writeln(a);
max := a[1];
for i := 1 to 10 do
begin
if max < a[i] then begin
max := a[i];
s := i
end;
end;
x := a[1];
a[1] := a[s];
a[s] := x;
writeln(a)
end.
a: array [1..10] of integer;
i, max, s, x: integer;
begin
s:=1;
randomize;
for i := 1 to 10 do
begin
a[i] := random(10) + 1
end;
writeln(a);
max := a[1];
for i := 1 to 10 do
begin
if max < a[i] then begin
max := a[i];
s := i
end;
end;
x := a[1];
a[1] := a[s];
a[s] := x;
writeln(a)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, давай составим программу на Python. Ты хочешь использовать какие-то конкретные библиотеки для генерации случайных чисел или можем использовать стандартную библиотеку `random`?
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
