Напишите программу запрашивающую 3 числа и выводящую их в порядке возрастания.
Ответы на вопрос
// Внимание! Если программа не работает, обновите версию!
Begin
var (a,b,c):=ReadInteger3('a, b, c ->');
var x:= min(a,min(b,c));
var y:= max(a,max(b,c));
var z:= 0;
if (a <> x)and(a <> y)
then z:= a;
if (b <> x)and(b <> y)
then z:= b;
if (c <> x)and(c <> y)
then z:= c;
Writeln(x, ' ', z, ' ', y);
end.
2 в порядке возрастания
тебе надо 2:
Program Rick_and_Morty;
var x,y,z:integer;
Begin
write('введите 1 число: ');
readln (x);
write('введите 2 число: ');
readln (y);
write('введите 3 число: ');
readln (z);
if ((x<=y) and (x<=z))then
begin if (y<=z) then
writeln(x,',',y,',',z)
else
writeln(x,',',z,',',y);
end
else
if ((y<=x) and (y<=z))then
begin
if (x<=z) then
writeln(y,',',x,',',z)
else
writeln(y,',',z,',',x)
end
else
if ((x<=y)) then
writeln(z,',',x,',',y)
else
writeln(z,',',y,',',x);
writeln('конец');
end.
Я могу помочь вам с написанием программы, запрашивающей три числа и выводящей их в порядке возрастания. Вот один из возможных вариантов решения этой задачи на языке Python:
```python # Запрашиваем три числа от пользователя и преобразуем их в целые числа a = int(input("Введите первое число: ")) b = int(input("Введите второе число: ")) c = int(input("Введите третье число: "))
# Создаем список из трех чисел numbers = [a, b, c]
# Сортируем список по возрастанию numbers.sort()
# Выводим отсортированный список на экран print("Числа в порядке возрастания:", numbers) ```
Эта программа использует встроенный метод `sort()` для сортировки списка чисел по возрастанию. Вы можете узнать больше о методе `sort()` здесь. Надеюсь, это поможет вам с вашим заданием.
: https://docs.python.org/3/howto/sorting.html#sortinghowto
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
