 
Задача в delphi. Составить программу для нахождения суммы: 2!+3!+4!+...+N!
 0
        0
         0
        0
    Ответы на вопрос
 
        program ConsoleProgram;
{$APPTYPE CONSOLE}
var valueN,sum,i,i2,tmp:longint;
begin
sum:=0;
readln(valueN);
for i:=1 to valueN do
begin
tmp:=1;
for i2:=1 to i do
tmp:=tmp*i2;
sum:=sum+tmp;
end;
writeln(sum);
readln;
end.
 0
                    0
                     0
                    0
                 
            Конечно, задача заключается в написании программы на Delphi для вычисления суммы факториалов от 2! до N!.
Факториал числа - это произведение всех положительных целых чисел от 1 до самого числа. Например, 4! (читается как "четыре факториал") равен 4 * 3 * 2 * 1 = 24.
Вот пример программы на Delphi, которая находит сумму факториалов от 2! до N!:
```delphi program SumOfFactorials;
uses SysUtils;
function Factorial(n: Integer): Int64; begin if (n = 0) or (n = 1) then Result := 1 else Result := n * Factorial(n - 1); end;
function SumOfFactorialsUpToN(N: Integer): Int64; var i: Integer; sum: Int64; begin sum := 0; for i := 2 to N do sum := sum + Factorial(i); Result := sum; end;
var N: Integer; sumResult: Int64; begin Write('Введите значение N для вычисления суммы факториалов от 2! до N!: '); Readln(N);
sumResult := SumOfFactorialsUpToN(N); Writeln('Сумма факториалов от 2! до ', N, '! равна ', sumResult);
Readln; end. ```
Эта программа начинает с ввода значения N с клавиатуры. Затем она вычисляет сумму факториалов от 2! до N! с помощью двух функций: `Factorial`, вычисляющей факториал числа, и `SumOfFactorialsUpToN`, вычисляющей сумму факториалов.
Программа выводит результат на экран.
Ты можешь использовать этот код в среде разработки Delphi для запуска и получения суммы факториалов от 2! до заданного числа N!.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			