Вопрос задан 08.05.2019 в 07:22.
Предмет Информатика.
Спрашивает Мусаева Алсу.
Составить программу с постусловием "является ли число простым" на языке паскаль
Ответы на вопрос
Отвечает Бойко Диана.
Вот так,скорее всего?
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Я попробую составить программу с постусловием "является ли число простым" на языке Паскаль. Вот мой код:
```pascal program PrimeNumber; var n, i, count: integer; begin writeln('Введите целое число больше 1'); readln(n); count := 0; for i := 2 to n - 1 do begin if n mod i = 0 then count := count + 1; end; if count = 0 then writeln('Число ', n, ' является простым') else writeln('Число ', n, ' не является простым'); end. ```
Программа считывает целое число больше 1 от пользователя и проверяет, делится ли оно на какое-либо число от 2 до n - 1. Если нет, то число является простым, иначе - нет. Программа выводит результат на экран. Это постусловие, потому что проверка происходит после ввода числа.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
