
Вопрос задан 14.05.2018 в 15:47.
Предмет Информатика.
Спрашивает Лазаренко Людмила.
Помогите составить программу на паскале Вычислить сумму чисел натурального ряда, делящихся на 3, до
тех пор, пока сумма не превысит 500. Определить число членов суммы. Значение суммы и число ее членов вывести на экран с соответствующими комментариями.

Ответы на вопрос

Отвечает Першичева Полина.
Вроде получилось:
var a,b,s:integer;
begin
write('Числа = ');
for a:=1 to 100 do
begin
b:=a mod 3;
if (b = 0) then
begin
write(a,', ');
s:=s+a;
if((s > 500) and (s<520)) then break;
end;
end;
writeln('Сумма чисел = ', s);
end.
Результат:



Топ вопросов за вчера в категории Информатика

Информатика 572

Информатика 1113

Информатика 10

Информатика 32

Информатика 16

Информатика 578

Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili