Вопрос задан 07.05.2019 в 10:27. Предмет Информатика. Спрашивает Касимов Тимур.

Паскаль: Написать программу для определения максимального элемента в одномерном массиве случайных

вещественных чисел C[80]. Найти сумму всех элементов. Оформить ввод/вывод массива.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Иванов Денис.
Var A:array [1..100] of real;
max:real; N,I:integer;
begin
N:=80;
for I:=1 to N do begin
a[I]:=random (20,5);
max:=a[1];
Sum:=Sum+a[I];
end;
for I:=1 to N do
if a[I] >max then max:=a[I];
for I:=1 to N do
write (A[I]:3);
writeln;
writeln (max);
writeln (sum);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Pascal, который решает вашу задачу. Программа генерирует случайные вещественные числа, заполняет массив C[80], определяет максимальный элемент и суммирует все элементы массива.

```pascal program MaxElementAndSum;

const N = 80; // Размер массива

var C: array[1..N] of Real; // Объявление массива i: Integer; maxElement: Real; sum: Real;

begin // Инициализация генератора случайных чисел Randomize;

// Заполнение массива случайными вещественными числами for i := 1 to N do begin C[i] := Random * 100; // Умножаем на 100 для получения чисел в диапазоне от 0 до 100 end;

// Вывод массива writeln('Массив C:'); for i := 1 to N do begin writeln(C[i]:10:2); // Вывод элемента массива с двумя знаками после запятой end;

// Поиск максимального элемента maxElement := C[1]; for i := 2 to N do begin if C[i] > maxElement then begin maxElement := C[i]; end; end;

// Вычисление суммы элементов sum := 0; for i := 1 to N do begin sum := sum + C[i]; end;

// Вывод результатов writeln('Максимальный элемент массива: ', maxElement:10:2); writeln('Сумма элементов массива: ', sum:10:2);

readln; end. ```

Эта программа использует генератор случайных чисел для заполнения массива C случайными вещественными числами от 0 до 100. Затем она находит максимальный элемент и суммирует все элементы массива. Результаты выводятся на экран.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос