ПАСКАЛЬ! нужно составить программы, чтобы из слова перестройка получить 10 новых слов!ребята,
плиииз(Ответы на вопрос
очень лень писать, дам направление как составлять слова из данного на языке, кстати способ очень глупый, я думаю если начнешь делать сам, то ты меня поймешь
var s,s1,s2,s3,s4,s5,s6,s7,s8,s9,s10:string;
begin
s:='перестройка';
writeln(s[5]+s[6]+s[7]+s[8]+s[9]+s[10]+s[11]); //получится слово стройка
writeln....
ну и так далее, удачи
Перестройка слова "перестройка" для получения 10 новых слов на языке Паскаль
Для составления программы на языке Паскаль, которая будет перестраивать слово "перестройка" для получения 10 новых слов, можно использовать различные алгоритмы и подходы. Вот один из возможных вариантов решения:
```pascal program Perestroika;
var word: string; permutations: array[1..10] of string; i: integer;
procedure Permute(var s: string; l, r: integer); var i: integer; temp: char; begin if l = r then begin permutations[i] := s; i := i + 1; end else begin for i := l to r do begin temp := s[l]; s[l] := s[i]; s[i] := temp; Permute(s, l + 1, r); temp := s[l]; s[l] := s[i]; s[i] := temp; end; end; end;
begin word := 'перестройка'; i := 1; Permute(word, 1, Length(word)); for i := 1 to 10 do writeln(permutations[i]); end. ```
В этой программе используется рекурсивная процедура `Permute`, которая генерирует все возможные перестановки букв в слове. Затем, с помощью цикла `for`, выводятся первые 10 полученных перестановок.
Примечание: Пожалуйста, обратите внимание, что код представлен в качестве примера и может потребовать доработки или оптимизации в зависимости от требований и спецификаций вашей задачи.
Надеюсь, это поможет вам составить программу на языке Паскаль для перестройки слова "перестройка" и получения 10 новых слов. Если у вас возникнут еще вопросы, пожалуйста, не стесняйтесь задавать их!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
