
PASCAL ABCСоставить программу, которая определяет подходит кандидат на работу или нет.Возраст:не
больше 50, не меньше 17Стаж:не менее 3-х летЗадача2Даны три числа, определить сколько чётныхЗадача3Является ли 4-х значное число палендромом

Ответы на вопрос

var
age : integer;
begin
read (age);
if (age > 50) or (age < 17) then writeln ('No') else writeln ('Yes');
end.
var
a, b, c, count : integer;
begin
read (a, b, c);
count := 3 - a mod 2 - b mod 2 - c mod 2;
writeln (count);
end.
var
k : integer;
begin
read (k);
if (k mod 1000 div 100 = k mod 100 div 10) and (k div 1000 = k mod 10) then writeln ('Yes') else writeln ('No');
end.



Program to Determine Job Candidate Eligibility
Here is a Pascal ABC program that determines whether a job candidate is eligible based on age and work experience criteria:
```pascal program JobCandidateEligibility;
var age, experience: integer;
begin writeln('Enter candidate age:'); readln(age); writeln('Enter candidate work experience (in years):'); readln(experience); if (age >= 17) and (age <= 50) and (experience >= 3) then writeln('The candidate is eligible for the job.') else writeln('The candidate is not eligible for the job.'); end. ```
In this program, the user is prompted to enter the candidate's age and work experience. The program then checks if the age is between 17 and 50 (inclusive) and if the work experience is at least 3 years. If both conditions are met, the program outputs that the candidate is eligible for the job. Otherwise, it outputs that the candidate is not eligible.
Program to Determine the Number of Even Numbers
Here is a Pascal ABC program that determines the number of even numbers among three given numbers:
```pascal program CountEvenNumbers;
var num1, num2, num3: integer; count: integer;
begin writeln('Enter three numbers:'); readln(num1, num2, num3); count := 0; if num1 mod 2 = 0 then count := count + 1; if num2 mod 2 = 0 then count := count + 1; if num3 mod 2 = 0 then count := count + 1; writeln('The number of even numbers is: ', count); end. ```
In this program, the user is prompted to enter three numbers. The program then checks each number to see if it is even (i.e., divisible by 2) using the modulo operator (%). If a number is even, the count variable is incremented by 1. Finally, the program outputs the total count of even numbers.
Program to Check if a 4-Digit Number is a Palindrome
Here is a Pascal ABC program that checks if a 4-digit number is a palindrome:
```pascal program CheckPalindrome;
var number, originalNumber, reverseNumber: integer;
begin writeln('Enter a 4-digit number:'); readln(number); originalNumber := number; reverseNumber := 0; while number > 0 do begin reverseNumber := reverseNumber * 10 + number mod 10; number := number div 10; end; if originalNumber = reverseNumber then writeln('The number is a palindrome.') else writeln('The number is not a palindrome.'); end. ```
In this program, the user is prompted to enter a 4-digit number. The program then reverses the number by repeatedly extracting the last digit using the modulo operator (%) and building the reverse number by multiplying it by 10 and adding the extracted digit. Finally, the program compares the original number with the reverse number to determine if it is a palindrome (i.e., the same number when read forwards and backwards).


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili