Ребята, кто разбирается в программировании, помогите! Составьте программу, вычисляющую, сколько
процентов от А+В-С приходится: а) на А б) на Б в) на ВОтветы на вопрос
uses crt;
var
a,b,c,d,pa,pb,pc:real;
begin
writeln('Введите А: ');
read(a);
writeln('Введите В: ');
read(b);
writeln('Введите C: ');
read(c);
d:=a+b+c;
pa:=(a/d)*100;
pb:=(b/d)*100;
pc:=(c/d)*100;
writeln('На А приходиться ',pa:2:2,' на В ',pb:2:2,' на С ',pc:2:2); //значание округлены до 2 знаков
end.
Конечно, я могу помочь вам с этим заданием!
Программа для вычисления процентного соотношения от A, B и C может выглядеть следующим образом на языке программирования Python:
```python # Вводим значения A, B и C A = float(input("Введите значение A: ")) B = float(input("Введите значение B: ")) C = float(input("Введите значение C: "))
# Вычисляем процентное соотношение total = A + B + C a_percent = (A / total) * 100 b_percent = (B / total) * 100 c_percent = (C / total) * 100
# Выводим результат print("Процентное соотношение:") print("A: {:.2f}%".format(a_percent)) print("B: {:.2f}%".format(b_percent)) print("C: {:.2f}%".format(c_percent)) ```
Эта программа позволяет пользователю ввести значения A, B и C, затем вычисляет процентное соотношение каждого значения от общей суммы (A + B + C) и выводит результат на экран. Результат выводится с округлением до двух десятичных знаков.
Вы можете запустить эту программу на своем компьютере, введя значения A, B и C, и она выведет процентное соотношение каждого значения.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
