Паскаль. Написать программу. Человек хочет положить деньги в банк под a% годовых на b лет.
Посчитать и вывести на экран суммы, которые он может получить по истечении каждого из этих лет.Ответы на вопрос
begin
writeln('Введите через пробел: сумму, годовой процент, количество лет');
read(c,a,b);
repeat
c:=c+0.01*a*c;
b:=b-1;
writeln('Сумма, которую можно получить = ',c);
until b=0;
end.
Программа для расчета суммы вклада в банк
Для написания программы, которая будет рассчитывать сумму, которую человек может получить по истечении каждого года вклада под определенный процент годовых, можно использовать язык программирования Pascal.
Вот пример программы на Pascal, которая решает данную задачу:
```pascal program BankDeposit; var principal, interestRate, years: real; totalAmount: real; i: integer; begin // Ввод данных пользователем writeln('Введите сумму вклада:'); readln(principal); writeln('Введите процент годовых:'); readln(interestRate); writeln('Введите количество лет:'); readln(years); // Расчет и вывод суммы по истечении каждого года for i := 1 to trunc(years) do begin totalAmount := principal * (1 + interestRate / 100); writeln('Сумма по истечении ', i, ' года: ', totalAmount:0:2); principal := totalAmount; end; end. ```
Программа запрашивает у пользователя сумму вклада, процент годовых и количество лет. Затем она использует цикл `for` для расчета и вывода суммы по истечении каждого года. Каждый раз, когда проходит один год, сумма вклада увеличивается на процент годовых.
Пример работы программы:
``` Введите сумму вклада: 10000 Введите процент годовых: 5 Введите количество лет: 3
Сумма по истечении 1 года: 10500.00 Сумма по истечении 2 года: 11025.00 Сумма по истечении 3 года: 11576.25 ```
Программа рассчитывает и выводит сумму по истечении каждого года вклада. Обратите внимание, что в данном примере вводятся только целочисленные значения для количества лет. Если вам нужно использовать дробные значения, то вам потребуется внести соответствующие изменения в программу.
Обратите внимание: Приведенный выше код является примером и может быть модифицирован или оптимизирован в соответствии с вашими потребностями.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
