
Дан массив из 5 элементов, найти среднее арифметическое всех элементов массива. Выполнять на
паскале. Нужно написать программу самым легким способом.

Ответы на вопрос

m : array[1..5] of Integer;
i,s : Integer;
Begin
s:=0;
Writeln('Введите 5 элементов:');
For i:=1 to 5 do
Begin
Readln(m[i]);
s:=s+m[i];
end;
Writeln('Среднее арифметическое: ',s/5);
end.



Для нахождения среднего арифметического всех элементов массива из 5 элементов на языке Pascal, вам потребуется написать программу. Вот пример программы, которая решает эту задачу:
```pascal program AverageArray;
var arr: array[1..5] of integer; sum, average: real; i: integer;
begin sum := 0;
// Ввод элементов массива writeln('Введите элементы массива:'); for i := 1 to 5 do begin write('Элемент ', i, ': '); readln(arr[i]); sum := sum + arr[i]; end;
// Вычисление среднего арифметического average := sum / 5;
// Вывод результата writeln('Среднее арифметическое: ', average:0:2); end. ```
В этой программе мы объявляем массив `arr` из 5 элементов типа `integer`, переменные `sum` и `average` для хранения суммы элементов и среднего арифметического соответственно, и переменную `i` для цикла.
Затем мы вводим элементы массива с помощью цикла `for`, вычисляем сумму элементов и сохраняем ее в переменной `sum`. После этого вычисляем среднее арифметическое, разделив сумму на количество элементов в массиве (в данном случае 5).
Наконец, выводим среднее арифметическое на экран с помощью `writeln`.
Примечание: Пожалуйста, убедитесь, что вы используете среду разработки, поддерживающую язык Pascal, чтобы запустить эту программу.


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili