Вопрос задан 06.05.2019 в 03:53. Предмет Информатика. Спрашивает Баяндин Кирилл.

Написать программу на Паскале, которая считает произведение чисел, которые больше введенного числа,

до 100. Числа только положительные.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кот Даниил.
Решение с использование длинной арифметики.
var
  i, j, n, len, rem: integer;
  a: array[1..200] of byte;
begin
  write('Введите число: ');
  read(n);
  len := 1;
  a[1] := 1;
  for i := n + 1 to 99 {100} do
  begin
    for j := 1 to len do
    begin
      rem := a[j] * i + rem;
      a[j] := rem mod 10;
      rem := rem div 10;
    end;
    while rem > 0 do
    begin
      inc(len);
      a[len] := rem mod 10;
      rem := rem div 10;
    end;
  end;
  writeln('Произведение чисел из интервала (', n, '; 100): ');
  for i := len downto 1 do write(a[i]);
end.
Пример работы программы:
Введите число: 1
Произведение чисел из интервала (1; 100):
1948348720420644788695888257080283249381963823594360049498643927185579338215778728274424636079639781709574621897447185108592230400000000000000000000


0 0
Отвечает Шамсутдинов Игорь.
Var  s: real; 
a,x:integer;
begin 
writeln('введите целое число'); 
readln(a); 
s := 1; 
a := a + 1; 
for x := a to 100 {или 99, зависит от того, включается 100 или нет} do   begin   
s := s * a; 
 a := a + 1;
end; 
writeln(s);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на Паскале, которая считает произведение чисел, которые больше введенного числа до 100:

``` program Multiplication;

var inputNumber, product: integer; i: integer;

begin // Ввод числа write('Введите число: '); readln(inputNumber);

// Инициализация произведения product := 1;

// Вычисление произведения for i := inputNumber + 1 to 100 do begin product := product * i; end;

// Вывод произведения writeln('Произведение чисел больше ', inputNumber, ' до 100: ', product);

// Ожидание ввода пользователя перед закрытием программы readln; end. ```

В этой программе мы сначала запрашиваем у пользователя ввод числа. Затем мы инициализируем переменную `product` значением 1, так как умножение на 1 не изменяет результат. Далее мы используем цикл `for`, чтобы умножить все числа от `inputNumber + 1` до 100 на `product`. Наконец, мы выводим результат произведения на экран.

Программа ожидает ввода пользователя перед закрытием, чтобы вы могли увидеть результат.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос