Вопрос задан 05.05.2019 в 22:09.
Предмет Информатика.
Спрашивает Тимуш Лена.
Помогите решить кто знает паскаль Вот задача Дан файл с оценками .txt учащихся Написать программу
которая определяет количество пятерок, четвёрок, троек. Вывести их количество на экран. Нужно написать в текстовом документе а с помощью Паскаля это прочитать Пожалуйста!!!!Ответы на вопрос
Отвечает Белов Андрей.
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
var a:=ReadallLines('in.txt')[0].ToIntegers;
Writeln('Исходный набор отметок'); a.Println;
var k3:=a.Where(x->x=3).Count;
var k4:=a.Where(x->x=4).Count;
var k5:=a.Where(x->x=5).Count;
Writeln('Троек- ',k3,', четверок- ',k4,', пятерок-',k5)
end.
Тестовое решение
Исходный набор отметок
3 4 4 5 5 3 4 4 5 4 3 5 5 3 5 3 4 3 3 4 5 4 4 3 4 4 3 4 5 4
Троек- 9, четверок- 13, пятерок-8
Файл с отметками in.txt дан во вложении.
begin
var a:=ReadallLines('in.txt')[0].ToIntegers;
Writeln('Исходный набор отметок'); a.Println;
var k3:=a.Where(x->x=3).Count;
var k4:=a.Where(x->x=4).Count;
var k5:=a.Where(x->x=5).Count;
Writeln('Троек- ',k3,', четверок- ',k4,', пятерок-',k5)
end.
Тестовое решение
Исходный набор отметок
3 4 4 5 5 3 4 4 5 4 3 5 5 3 5 3 4 3 3 4 5 4 4 3 4 4 3 4 5 4
Троек- 9, четверок- 13, пятерок-8
Файл с отметками in.txt дан во вложении.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на яз
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
