Написать программу, в результате работы которой будут заполнятся и выводится в строчку на экран
целочисленный массив C из 7 элементов. Значения элементов массива находятся в диапазоне от −10 до 10 и заполняются случайным образом. Выполнить: поиск наибольшего сортиовать по возрастаниюОтветы на вопрос
#include <algorithm>
#include <ctime>
using namespace std;
const int ARRAY_SIZE = 7;
int c[ARRAY_SIZE];
void print_array();
int main(int argc, char *argv[])
{
srand ( time(NULL) );
cout << "--- ЗАПОЛНЕНИЕ МАССИВА ---\n";
for (int i = 0; i < ARRAY_SIZE; ++i) {
c[i] = rand() % 21 - 10;
cout << c[i] << ' ';
}
cout << "\n--- МАССИВ ЗАПОЛНЕН ---\n";
cout << "--- ПОИСК НАИБОЛЬШЕГО ---\n";
int max = c[0];
for (int i = 0; i < ARRAY_SIZE; ++i) {
if (c[i] > max) max = c[i];
}
cout << "--- ПОИСК ЗАВЕРШЁН ---\n"
<< "Наибольшее: " << max << '\n'
<< "--- НАЧАЛО СОРТИРОВКИ ---\n";
sort(c, c + ARRAY_SIZE);
cout << "--- МАССИВ ОТСОРТИРОВАН ---\n";
print_array();
return 0;
}
void print_array() {
cout << "--- ВЫВОД НА ЭКРАН ---\n";
for (int i = 0; i < ARRAY_SIZE; ++i) {
cout << c[i] << ' ';
}
cout << "\n--- КОНЕЦ ВЫВОДА ---\n";
}
Программа для заполнения и сортировки массива
Для решения данной задачи, можно написать программу на языке C++, которая будет заполнять и выводить на экран целочисленный массив из 7 элементов. Значения элементов массива будут находиться в диапазоне от -10 до 10 и заполняться случайным образом. Затем программа будет выполнять поиск наибольшего элемента и сортировку массива по возрастанию.
Вот пример программы на языке C++:
```cpp
#include
int main() { // Задаем размер массива const int size = 7; // Задаем диапазон значений элементов массива const int min_value = -10; const int max_value = 10; // Инициализируем генератор случайных чисел std::srand(std::time(nullptr)); // Создаем и заполняем массив случайными значениями int array[size]; for (int i = 0; i < size; i++) { array[i] = std::rand() % (max_value - min_value + 1) + min_value; } // Выводим исходный массив на экран std::cout << "Исходный массив: "; for (int i = 0; i < size; i++) { std::cout << array[i] << " "; } std::cout << std::endl; // Находим наибольший элемент массива int max_element = *std::max_element(array, array + size); // Выводим наибольший элемент на экран std::cout << "Наибольший элемент: " << max_element << std::endl; // Сортируем массив по возрастанию std::sort(array, array + size); // Выводим отсортированный массив на экран std::cout << "Отсортированный массив: "; for (int i = 0; i < size; i++) { std::cout << array[i] << " "; } std::cout << std::endl; return 0; } ```
Программа использует библиотеки `iostream`, `cstdlib`, `ctime` и `algorithm` для работы с вводом-выводом, генерацией случайных чисел, временем и сортировкой соответственно. Она создает массив заданного размера, заполняет его случайными значениями в заданном диапазоне, находит наибольший элемент, сортирует массив по возрастанию и выводит результаты на экран.
Примечание: В программе использована функция `std::rand()`, которая генерирует псевдослучайные числа. Для получения разных последовательностей случайных чисел при каждом запуске программы, используется функция `std::srand(std::time(nullptr))`, которая инициализирует генератор случайных чисел текущим временем.
Надеюсь, данная информация будет полезной! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать их.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
