Вопрос задан 05.05.2019 в 15:40. Предмет Информатика. Спрашивает Кедышко Тарас.

Напишите программу, которая вводила бы с клавиатуры 10 вещественных чисел и вычисляла бы их среднее

арифметическоев Pascal
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сидорик Світлана.
Program Lemonly;
const
  n=10;
var
  table: array [1..n] of real;
  i: integer;
  sum,arifm: real;
begin
  randomize;
  sum:=0;
  writeln ('Введите ', n, ' чисел:');
 for i:= 1 to n do
    begin
    readln(table[i]);
    sum:=sum+table[i];
    end;
  writeln();
  arifm:=sum/n;
  writeln ('Cреднее арифметическое введённых чисел равно ',arifm:8:3);
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам написать программу на языке Pascal, которая вводила бы с клавиатуры 10 вещественных чисел и вычисляла бы их среднее арифметическое. Вот пример такой программы:

```pascal program average; var i: integer; // счетчик цикла x: real; // текущее введенное число sum: real; // сумма введенных чисел avg: real; // среднее арифметическое begin sum := 0; // инициализируем сумму нулем writeln('Введите 10 вещественных чисел:'); for i := 1 to 10 do // повторяем 10 раз begin readln(x); // считываем число с клавиатуры sum := sum + x; // добавляем его к сумме end; avg := sum / 10; // делим сумму на 10, получаем среднее writeln('Среднее арифметическое = ', avg:0:2); // выводим среднее с двумя знаками после запятой end. ```

Вы можете запустить эту программу в онлайн-компиляторе Pascal, например, [здесь]. Надеюсь, это поможет вам.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос