 
Написать программу на Pascal, которая сообщает о равенстве или не равенстве последних цифр трех
заданных чисел. Заранее спасибо. Если можно, то пожалуйста с объяснениями... 0
        0
         0
        0
    Ответы на вопрос
 
        //Внимание! Если программа не работает, обновите версию!
begin
var (a,b,c):=readinteger3('a,b,c->'); a:=a mod 10 ; b:= b mod 10;
c:=c mod 10;
if (a=b) and (b=c) then writeln('последних цифры равны ') else
writeln('последних цифры не равны ');
end.
 0
                    0
                     0
                    0
                 
            Конечно, вот пример программы на Pascal, которая определяет равенство или не равенство последних цифр трех заданных чисел:
```pascal program LastDigitsEquality;
var num1, num2, num3: integer; lastDigit1, lastDigit2, lastDigit3: integer;
begin // Вводим три числа write('Введите первое число: '); readln(num1); write('Введите второе число: '); readln(num2); write('Введите третье число: '); readln(num3);
// Определяем последнюю цифру каждого числа lastDigit1 := num1 mod 10; lastDigit2 := num2 mod 10; lastDigit3 := num3 mod 10;
// Проверяем равенство последних цифр if (lastDigit1 = lastDigit2) and (lastDigit2 = lastDigit3) then writeln('Последние цифры всех трех чисел равны') else writeln('Последние цифры трех чисел не равны'); end. ```
В данной программе используется переменные `num1`, `num2` и `num3` для хранения трех заданных чисел. Затем с помощью оператора `mod` находим остаток от деления каждого числа на 10, чтобы получить последнюю цифру.
Далее мы сравниваем последние цифры всех трех чисел с помощью оператора `=`. Если все три последние цифры равны, то выводим сообщение "Последние цифры всех трех чисел равны", иначе выводим сообщение "Последние цифры трех чисел не равны".
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			