
Составить программу. Ввести 2 числа, если их произведение отрицательно, то умножить его на -2 и
вывести на экран, если нет, то увеличить его в 3 раза и вывести на экран.

Ответы на вопрос

var a,b,c,d:integer;
begin
writeln('Введи 2 числа: ');
readln(a,b);
c:=a*b;
if c<0 then d:=c*(-2)
else
d:=c*3;
writeln(d);
end.



Программа для проверки произведения двух чисел
Для создания программы, которая вводит два числа, проверяет их произведение и выполняет соответствующие действия в зависимости от результата, можно использовать следующий код на Python:
```python # Ввод двух чисел num1 = float(input("Введите первое число: ")) num2 = float(input("Введите второе число: "))
# Проверка произведения и выполнение соответствующих действий product = num1 * num2 if product < 0: result = product * (-2) print("Произведение отрицательно, умножаем на -2:", result) else: result = product * 3 print("Произведение неотрицательно, увеличиваем в 3 раза:", result) ```
При вводе двух чисел программа сначала проверяет произведение и затем выводит соответствующий результат на экран.
Исходный код программы
```python # Ввод двух чисел num1 = float(input("Введите первое число: ")) num2 = float(input("Введите второе число: "))
# Проверка произведения и выполнение соответствующих действий product = num1 * num2 if product < 0: result = product * (-2) print("Произведение отрицательно, умножаем на -2:", result) else: result = product * 3 print("Произведение неотрицательно, увеличиваем в 3 раза:", result) ```
Этот код сначала запрашивает у пользователя ввод двух чисел, затем проверяет произведение и выводит соответствующий результат на экран.
Объяснение кода
1. Программа запрашивает у пользователя ввод двух чисел с помощью `input()`. 2. Затем производит умножение этих двух чисел и сохраняет результат в переменной `product`. 3. Далее, с помощью условного оператора `if-else`, программа проверяет, является ли произведение отрицательным. 4. Если произведение отрицательно, то оно умножается на -2 и выводится на экран. 5. Если произведение неотрицательно, то оно увеличивается в 3 раза и также выводится на экран.
Таким образом, программа выполняет требуемые действия в зависимости от результата произведения введенных чисел.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili