Написать программу определяющую равны ли друг другу три введенные с клавиатуры числа
Ответы на вопрос
var a,b,c:integer;
begin
writeln('Vvedite 3 chisla');
readln(a,b,c);
if (a=b) and (b=c) then write('Ravni') else write('Ne ravni');
end.
Я могу помочь вам с написанием программы, которая определяет, равны ли друг другу три введенные с клавиатуры числа. Вот один из возможных вариантов решения этой задачи на языке Python:
```python # Вводим три числа с клавиатуры и преобразуем их в целые числа a = int(input("Введите первое число: ")) b = int(input("Введите второе число: ")) c = int(input("Введите третье число: "))
# Проверяем, равны ли они друг другу, используя оператор == if a == b == c: # Если да, то выводим сообщение об этом print("Все три числа равны") else: # Если нет, то выводим сообщение об этом print("Числа не равны") ```
Эта программа считывает три числа с клавиатуры, используя функцию `input()`, и преобразует их в целые числа, используя функцию `int()`. Затем она сравнивает их между собой, используя оператор `==`, который возвращает `True`, если два значения равны, и `False`, если они различны. Если все три числа равны, то программа выводит сообщение "Все три числа равны", иначе она выводит сообщение "Числа не равны".
Вы можете найти больше информации о языке Python и его синтаксисе на [официальном сайте](https://ru.stackoverflow.com/questions/1260054/%d0%9a%d0%b0%d0%ba-%d0%bf%d1%80%d0%be%d0%b2%d0%b5%d1%80%d0%b8%d1%82%d1%8c-%d0%b2%d0%b2%d0%b5%d0%b4%d0%b5%d0%bd%d0%bd%d1%8b%d0%b5-%d1%81-%d0%ba%d0%bb%d0%b0%d0%b2%d0%b8%d0%b0%d1%82%d1%83%d1%80%d1%8b-%d0%b4%d0%b0%d0%bd%d0%bd%d1%8b%d0%b5-%d1%81-%d0%bf%d0%be%d0%bc%d0%be%d1%89%d1%8c%d1%8e-java-util-scanner) или на [Stack Overflow на русском](https://otvet.mail.ru/question/222290451). Там вы также можете задавать вопросы и получать ответы от других программистов. Надеюсь, что моя помощь была полезной для вас.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
