
написать программу нахождения большего и меньшего из 3 чиселпомогите пожалуйстаааааааааа((((


Ответы на вопрос

var
a, b, c: real;
begin
writeln('Введите 3 любых числа');
readln(a, b, c);
if (a < b) and (a < c) then writeln(a, ' - наименьшее число');
if (b < a) and (b < c) then writeln(b, ' - наименьшее число');
if (c < a) and (c < b) then writeln(c, ' - наименьшее число');
if (a > b) and (a > c) then writeln(a, ' - наибольшее число');
if (b > a) and (b > c) then writeln(b, ' - наибольшее число');
if (c > a) and (c > b) then writeln(c, ' - наибольшее число');
readln; //Убрать если среда разработки не Turbo Pascal
end.



var a,b,c:integer;
begin
readln(a,b,c);
if (a>b) and (a>c) and (b>c) then writeln('c=',c,'a=',a) else
if (b>a) and (b>c) and (a>c) then writeln('c=',c,a,'b=',b) else
if (c>a) and (c>b) and (b>a) then writeln('a=',a,'c=',c) else
if (a>b) and (a>c) and (c>b) then writeln('b=',b,'a=',a) else
if (b>a) and (b>c) and (c>a) then writeln('a=',a,'b=',b) else
if (c>a) and (c>b) and (a>b) then writeln('b=',b,'c=',c) else
readln;
end



Конечно, я могу помочь вам написать программу для нахождения наибольшего и наименьшего из трех чисел. Вот пример программы на языке Python:
```python # Ввод трех чисел num1 = float(input("Введите первое число: ")) num2 = float(input("Введите второе число: ")) num3 = float(input("Введите третье число: "))
# Находим наибольшее число max_num = max(num1, num2, num3)
# Находим наименьшее число min_num = min(num1, num2, num3)
# Выводим результат print("Наибольшее число:", max_num) print("Наименьшее число:", min_num) ```
Вы можете скопировать этот код и запустить его в среде разработки Python или в онлайн-интерпретаторе, чтобы увидеть результат. Программа попросит вас ввести три числа, а затем выведет наибольшее и наим


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili