Напишите программу, которая считает произведенине нечетных чисел на заданном промежутке (паскаль)
Ответы на вопрос
var a,i,n,p:integer;
Begin
p:=1;
read(n);
for i:=1 to n do
begin
read(a);
if a mod 2<>0 then
p:=p*a;
end;
writeln(p);
End.
Вот пример программы на языке Pascal, которая считает произведение нечетных чисел на заданном промежутке:
```pascal program MultiplyOddNumbers;
var start, finish, i: Integer; product: LongInt;
begin // Ввод начального и конечного числа промежутка Write('Введите начальное число промежутка: '); ReadLn(start); Write('Введите конечное число промежутка: '); ReadLn(finish); product := 1; // Инициализация произведения
// Перебор чисел в промежутке for i := start to finish do begin // Проверка на нечетность if i mod 2 <> 0 then product := product * i; // Умножение на нечетное число end;
// Вывод результата WriteLn('Произведение нечетных чисел на заданном промежутке: ', product); end. ```
Программа сначала запрашивает у пользователя начальное и конечное число промежутка. Затем она инициализирует переменную `product` значением 1 и перебирает числа в заданном промежутке. Если число нечетное, оно умножается на текущее значение `product`. В конце программа выводит произведение нечетных чисел на заданном промежутке.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
