Вопрос задан 02.05.2019 в 12:00.
Предмет Информатика.
Спрашивает Смирнов Евгений.
Напишите программу, которая удаляет из строки все повторяющиеся символы. Входные данные На вход
программы подаётся строка, содержащая символы таблицы ASCII. Выходные данные Программа должна вывести исходную строку, из которой удалены все повторяющиеся символы. Примеры входные данные abc13a1b2z3c выходные данные abc132z входные данные QWasd123 выходные данные QWasd123 Pascal ABC 1.8Ответы на вопрос
Отвечает Коротаев Гоша.
Var s:string;
i,j:byte;
begin ;
writeln('Введите слово с повторябщимися символами');
readln(s); i:=1;
while i<length(s) do
if s[i]<>' ' then begin
for j:=length(s) downto i+1 do
if s[j]=s[i] then delete(s,j,1);
i:=i+1;
end
else i:=i+1;
write(s);
readln
end.
i,j:byte;
begin ;
writeln('Введите слово с повторябщимися символами');
readln(s); i:=1;
while i<length(s) do
if s[i]<>' ' then begin
for j:=length(s) downto i+1 do
if s[j]=s[i] then delete(s,j,1);
i:=i+1;
end
else i:=i+1;
write(s);
readln
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа для удаления повторяющихся символов из строки
Для решения этой задачи можно написать программу на Python. Вот пример программы:
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
