DELPHI. Написать программу, которая вводит массив из N целых чисел и выводит на экран этот же
массив в прямом и обратном порядке. Протестировать программу на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.Ответы на вопрос
handsfree = false;
var
a: array[1..100] of integer;
i, n: integer;
begin
{ввод массива}
if handsfree then
n := random(20) + 5
else begin
write('n = ');
readln(n);
end;
writeln('Данные массива:');
for i := 1 to n do
begin
if handsfree then begin
a[i] := random(100) - 50;
write(a[i], ' ');
end
else readln(a[i]);
end;
writeln();
{изменение элементов}
writeln('Вывод прямой:');
for i := 1 to n do
write(a[i], ' ');
writeln();
{изменение элементов}
writeln('Вывод обратный:');
for i := n downto 1 do
write(a[i], ' ');
end.
Программа на Delphi для вывода массива в прямом и обратном порядке
Вот пример программы на Delphi, которая вводит массив из N целых чисел и выводит его на экран в прямом и обратном порядке:
```delphi program ArrayReverse;
uses SysUtils;
const MAX_SIZE = 100;
type TIntArray = array[1..MAX_SIZE] of Integer;
procedure ReadArray(var arr: TIntArray; size: Integer); var i: Integer; begin for i := 1 to size do begin Write('Enter element ', i, ': '); ReadLn(arr[i]); end; end;
procedure PrintArray(var arr: TIntArray; size: Integer); var i: Integer; begin WriteLn('Array in direct order:'); for i := 1 to size do Write(arr[i], ' '); WriteLn; WriteLn('Array in reverse order:'); for i := size downto 1 do Write(arr[i], ' '); WriteLn; end;
var arr: TIntArray; size: Integer; begin Write('Enter the size of the array: '); ReadLn(size); if (size > 0) and (size <= MAX_SIZE) then begin ReadArray(arr, size); PrintArray(arr, size); end else WriteLn('Invalid array size.'); end. ```
Тестирование программы
Программу можно протестировать на произвольных массивах, состоящих из 1 числа, из 5 чисел и из 10 чисел. Вот примеры тестов:
1. Массив из 1 числа: - Ввод: `1` - Ожидаемый вывод: ``` Array in direct order: 1 Array in reverse order: 1 ```
2. Массив из 5 чисел: - Ввод: `5 10 15 20 25` - Ожидаемый вывод: ``` Array in direct order: 5 10 15 20 25 Array in reverse order: 25 20 15 10 5 ```
3. Массив из 10 чисел: - Ввод: `2 4 6 8 10 12 14 16 18 20` - Ожидаемый вывод: ``` Array in direct order: 2 4 6 8 10 12 14 16 18 20 Array in reverse order: 20 18 16 14 12 10 8 6 4 2 ```
Примечания
- Программа проверяет, что введенный размер массива находится в допустимых пределах (от 1 до 100). Если размер массива некорректный, программа выведет сообщение об ошибке. - Ввод и вывод элементов массива осуществляется с помощью стандартных процедур `ReadLn` и `WriteLn`. - Программа выводит массив как в прямом, так и в обратном порядке, используя циклы `for` и обращение к элементам массива по индексу.
Примечание: Информация в данном ответе основана на результате поиска, предоставленного You.com.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
