
1.Написать программу вывода чисел от a до b( a и b вводит пользователь) с шагом в 1. 2.Вывести их
произведение и сумму. программа С++. 50 баллов.

Ответы на вопрос

#include <iostream>
using namespace std;
int main()
{
int a, b;
cout << "a = ", cin >> a;
cout << "b = ", cin >> b;
for (int i=a; i<=b; i++) {
cout << i << " ";
}
return 0;
}
Пример:
a = 5
b = 12
5 6 7 8 9 10 11 12
2.
#include <iostream>
using namespace std;
int main()
{
int a, b, s=0;
long long p=1;
cout << "a = ", cin >> a;
cout << "b = ", cin >> b;
for (int i=a; i<=b; i++) {
p = p*i;
s = s+i;
}
cout << "p = " << p << " s = " << s;
return 0;
}
Пример:
a = 5
b = 12
p = 19958400 s = 68



Программа на C++ для вывода чисел от a до b с шагом 1, вычисления их произведения и суммы
Для начала, пользователь вводит два числа a и b, после чего программа выводит числа от a до b с шагом 1, вычисляет их произведение и сумму.
```cpp
#include
int main() { int a, b; cout << "Введите два числа a и b: "; cin >> a >> b;
int product = 1; int sum = 0;
for (int i = a; i <= b; i++) { cout << i << " "; product *= i; sum += i; }
cout << "\nПроизведение: " << product << endl; cout << "Сумма: " << sum << endl;
return 0; } ```
Эта программа сначала запрашивает у пользователя ввод двух чисел a и b. Затем она выводит числа от a до b с шагом 1, вычисляет их произведение и сумму.
Пример работы программы: ``` Введите два числа a и b: 3 6 3 4 5 6 Произведение: 360 Сумма: 18 ```
Этот код использует цикл for для вывода чисел от a до b с шагом 1 и одновременно вычисляет их произведение и сумму.
Надеюсь, это поможет! Если у вас есть еще вопросы или нужна дополнительная помощь, не стесняйтесь спрашивать.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili