Вопрос задан 01.05.2019 в 22:53. Предмет Информатика. Спрашивает Сиделов Серёжа.

Заранее спасибо :3 Напишите программу, которая определяет, попала ли точка с заданными координатами

в заштрихованную область. Входные данные Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x -координата, затем – y -координата). Выходные данные Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала. В ПАСКАЛЕ
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Макарова Светлана.
Var x,y : real;
begin
write('x = '); readln(x);
write('y = '); readln(y);
if (y>1-x)and(x<1)and((y>2*x*x)or(y<2*x*x)and(x>0))
  then writeln('YES') else writeln('NO')
end.

Пример:
x = 0.75
y = 1
YES
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос