
Напишите программу( в паскале авс), которая находит НОК (наименьшее общее кратное) двух чисел,
введённых с клавиатуры.

Ответы на вопрос

а*б=НОД(а,б)*НОК(а,б)
var a,b:longint;
function nod(a,b:longint):longint;
begin
if a= 0 then
nod:=b else
if b=0 then
nod:=a else
if a>b then
nod:=nod(a mod b,b) else
nod:=nod(a,b mod a);
end;
Begin
read(a,b);
writeln((a*b) div nod(a,b));
End.



Конечно, вот пример программы на языке Pascal, которая находит НОК (наименьшее общее кратное) двух чисел, введенных с клавиатуры:
```pascal program LeastCommonMultiple;
var num1, num2, gcd, lcm, temp: integer;
function FindGCD(a, b: integer): integer; begin if b = 0 then FindGCD := a else FindGCD := FindGCD(b, a mod b); end;
begin writeln('Введите первое число: '); readln(num1); writeln('Введите второе число: '); readln(num2); gcd := FindGCD(num1, num2); lcm := (num1 * num2) div gcd; writeln('Наименьшее общее кратное чисел ', num1, ' и ', num2, ' равно ', lcm); end. ```
Эта программа сначала запрашивает у пользователя ввод двух чисел. Затем она использует функцию FindGCD для нахождения наибольшего общего делителя (НОД) этих чисел. После этого программа вычисляет НОК по формуле НОК = (число1 * число2) / НОД и выводит результат на экран.
Надеюсь, это поможет вам понять, как написать программу для нахождения НОК на языке Pascal!


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili