Вопрос задан 30.04.2019 в 23:42. Предмет Информатика. Спрашивает Назаров Олег.

Написать в паскаль. Вводится предложение. Определить длину самого длинного слова.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ткаченко Даша.
Var s:string;
m,tmp,i:integer;
begin
readln(s);
for i:=1 to length(s) do begin
if (s[i]<>' ') then inc(tmp)
else begin 
  if tmp>m then m:=tmp;
  tmp:=0;
  end;
end;
if tmp>m then m:=tmp;
writeln(m);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь с этим. Чтобы написать программу на языке Паскаль для определения длины самого длинного слова во введенном предложении, вот пример кода:

```pascal program LongestWordLength; uses crt;

var sentence, word, longestWord: string; i, maxLength: integer;

begin clrscr; write('Введите предложение: '); readln(sentence); word := ''; longestWord := ''; maxLength := 0; for i := 1 to length(sentence) do begin if (sentence[i] <> ' ') then word := word + sentence[i] else begin if length(word) > maxLength then begin maxLength := length(word); longestWord := word; end; word := ''; end; end; // Check the last word in the sentence if length(word) > maxLength then begin maxLength := length(word); longestWord := word; end; writeln('Самое длинное слово: ', longestWord); writeln('Длина самого длинного слова: ', maxLength); readkey; end. ```

Эта программа просит пользователя ввести предложение, затем она находит самое длинное слово в предложении и выводит его длину. Надеюсь, это поможет вам в вашем задании!

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос