Написать программу на языке паскаль, возведение числа в степень. Степень вводится с клавиатуры.
Ответы на вопрос
var n,i:integer; x,xn:real;
begin
write('x = ');
readln(x);
write('n = ');
readln(n);
xn:=1;
for i:=1 to n do xn:=xn*x;
writeln('xn = ',xn:6:3);
end.
Пример:
x = 2
n = 5
xn = 32
Var
P:integer;
St:real;
Begin
Write('Показатель степени(целое число) = ');ReadLn(P);
St:=1;
For P:= 1 to P do
St:=St*2;
WriteLn('2^',P,' = ',St);
End.
Пример:
Показатель степени(целое число) = 4
2^4 = 16
Степень и число вводится с клавы:
Var
P:integer;
St,O:real;
Begin
Write('Показатель степени(целое число) = ');ReadLn(P);
Write('Основание степени(вещественное число) = ');ReadLn(O);
St:=1;
For P:= 1 to P do
St:=St*O;
WriteLn(O,'^',P,' = ',St);
End.
Пример:
Показатель степени(целое число) = 3
Основание степени(вещественное число) = 2.5
2.5^3 = 15.625
Программа на языке Паскаль для возведения числа в степень
Вот пример программы на языке Паскаль, которая позволяет возвести число в степень. Степень вводится с клавиатуры:
```pascal program PowerCalc;
var base, exponent, result: real;
begin // Ввод числа и степени с клавиатуры writeln('Введите число: '); readln(base); writeln('Введите степень: '); readln(exponent);
// Вычисление результата result := power(base, exponent);
// Вывод результата writeln('Результат: ', result); end. ```
В этой программе мы используем встроенную функцию `power`, которая позволяет возвести число в заданную степень. Функция `power` принимает два аргумента: число, которое нужно возвести в степень, и саму степень. Результат сохраняется в переменную `result`, которая затем выводится на экран.
Примечание: В данном примере используется тип данных `real` для чисел. Если вам нужно работать с целыми числами, вы можете использовать тип `integer` вместо `real`.
Надеюсь, эта программа поможет вам понять, как возвести число в степень на языке Паскаль. Если у вас возникнут дополнительные вопросы, пожалуйста, не стесняйтесь задавать их!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
