
Создать массив из n (n>2) чисел, в котором первые два элемента задаются с клавиатуры, а все
последующие равны сумме двух предыдущих элементов

Ответы на вопрос

Dim a() As Integer
n = InputBox("Сколько чисел?")
ReDim a(n)
For i = 1 To 2
a(i) = InputBox("Введите число")
Next i
s = a(1) & " " & a(2)
For i = 3 To n
a(i) = a(i - 2) + a(i - 1)
s = s & " " & a(i)
Next i
MsgBox ("Массив: " & s)
End Sub



Для создания массива из n (где n > 2) чисел, где первые два элемента задаются с клавиатуры, а все последующие элементы равны сумме двух предыдущих элементов, можно использовать следующий код на языке программирования C++:
```cpp
#include
int main() { int n; cout << "Введите количество элементов массива (n > 2): "; cin >> n;
int arr[n]; cout << "Введите первый элемент массива: "; cin >> arr[0]; cout << "Введите второй элемент массива: "; cin >> arr[1];
for (int i = 2; i < n; i++) { arr[i] = arr[i-1] + arr[i-2]; }
cout << "Массив из " << n << " чисел: "; for (int i = 0; i < n; i++) { cout << arr[i] << " "; }
return 0; } ```
В этом коде мы сначала запрашиваем у пользователя количество элементов массива (n), а затем запрашиваем первые два элемента массива. Затем мы используем цикл for для вычисления остальных элементов массива, где каждый элемент равен сумме двух предыдущих элементов. Наконец, мы выводим полученный массив на экран.
Пример работы программы:
``` Введите количество элементов массива (n > 2): 6 Введите первый элемент массива: 1 Введите второй элемент массива: 2 Массив из 6 чисел: 1 2 3 5 8 13 ```
Таким образом, мы создали массив из 6 чисел, где первые два элемента заданы пользователем, а остальные элементы равны сумме двух предыдущих элементов.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili