Вопрос задан 30.04.2019 в 07:06. Предмет Информатика. Спрашивает Родионов Тимофей.

Составить программу в Паскале - на вход программе подаются данные датчика температуры. Температура

изменяется 24 раза в стуки. Температура измеряется от 19 до 23 градусов, надо найти количество измерений в которых температура была 20 градусов Не толко ответ, но и программу расписать, буду благодарна
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бовырина Алина.
// PascalABC.NET 3.2, сборка 1345 от 24.11.2016
// Внимание! Если программа не работает, обновите её версию!
begin
  var t:=ArrRandom(24,19,23); t.Println;
  Writeln('Температура +20 была ',t.Where(x->x=20).Count,' раз(а)')
end.

Пример
23 22 22 23 20 19 19 21 19 20 22 20 21 22 20 19 22 22 21 20 21 21 23 23
Температура +20 была 5 раз(а)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на Паскале для подсчета количества измерений, в которых температура была 20 градусов

```pascal program TemperatureMeasurements;

var temperature: Integer; // переменная для хранения значения температуры count: Integer; // переменная для подсчета количества измерений с температурой 20 градусов i: Integer; // переменная для цикла

begin count := 0; // инициализация счетчика

for i := 1 to 24 do // цикл для 24 измерений begin // Ввод значения температуры с клавиатуры или из другого источника данных writeln('Введите значение температуры для измерения ', i, ':'); readln(temperature);

// Проверка, равна ли температура 20 градусам if temperature = 20 then count := count + 1; // увеличение счетчика, если температура равна 20 градусам end;

// Вывод результата writeln('Количество измерений, в которых температура была 20 градусов: ', count); end. ```

Программа представляет собой простой код на языке Паскаль, который позволяет подсчитать количество измерений, в которых температура была равна 20 градусам. В программе используется переменная `temperature` для хранения значения температуры, переменная `count` для подсчета количества измерений с температурой 20 градусов и переменная `i` для цикла.

Программа выполняет следующие шаги: 1. Инициализирует счетчик `count` значением 0. 2. Запускает цикл `for` с переменной `i` от 1 до 24, чтобы выполнить 24 измерения. 3. В каждой итерации цикла программа запрашивает у пользователя ввод значения температуры для текущего измерения. 4. Проверяет, равна ли введенная температура 20 градусам. Если да, то увеличивает счетчик `count` на 1. 5. По завершении цикла программа выводит количество измерений, в которых температура была 20 градусов.

Примечание: В данной программе предполагается, что пользователь будет вводить значения температуры вручную. Если данные должны поступать из датчика, то необходимо использовать соответствующие функции или процедуры для получения данных от датчика.

Надеюсь, эта программа поможет вам решить задачу подсчета количества измерений с температурой 20 градусов! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать их.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос