Помогите написать программу на PascalABC Создать программу: "Вводится n чисел. Найти среднее
арифметическое всех нечетных, кратных 3 чисел.Ответы на вопрос
begin
var n:=ReadInteger('n=');
var s:=0;
var k:=0;
var m:integer;
for var i:=1 to n do begin
Read(m);
if Odd(m) and (m mod 3 = 0) then begin
s+=m; Inc(k)
end
end;
if k>0 then Writeln(s/k)
else Writeln('Нет чисел, удовлетворяющих условию')
end.
Тестовое решение:
n= 10
6 3 12 15 -9 11 0 14 42 11
3
Программа на PascalABC: Нахождение среднего арифметического нечетных чисел, кратных 3
Для написания программы на PascalABC, которая будет находить среднее арифметическое всех нечетных чисел, кратных 3, можно использовать следующий код:
```pascal program AverageOfOddMultiplesOfThree;
var n, number, sum, count: integer; average: real;
begin sum := 0; count := 0;
writeln('Введите количество чисел:'); readln(n);
writeln('Введите ', n, ' чисел:');
for var i := 1 to n do begin readln(number);
if (number mod 2 <> 0) and (number mod 3 = 0) then begin sum := sum + number; count := count + 1; end; end;
if count > 0 then begin average := sum / count; writeln('Среднее арифметическое нечетных чисел, кратных 3: ', average:0:2); end else writeln('Нет нечетных чисел, кратных 3.');
readln; end. ```
Как работает программа:
1. Программа запрашивает у пользователя количество чисел `n`. 2. Затем программа просит пользователя ввести `n` чисел. 3. В цикле проверяется каждое введенное число: - Если число нечетное и кратно 3, то оно добавляется к сумме `sum` и увеличивается счетчик `count`. 4. После завершения цикла проверяется значение `count`: - Если `count` больше 0, то вычисляется среднее арифметическое `average` путем деления суммы `sum` на количество чисел `count`. - Если `count` равно 0, то выводится сообщение о том, что нет нечетных чисел, кратных 3. 5. Результат выводится на экран.
Пример использования программы:
``` Введите количество чисел: 5 Введите 5 чисел: 1 2 3 4 5 Среднее арифметическое нечетных чисел, кратных 3: 3.00 ```
Примечание: Пожалуйста, убедитесь, что у вас установлена среда разработки PascalABC.NET для запуска программы.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
