Вопрос задан 29.04.2019 в 20:17. Предмет Информатика. Спрашивает Рейдла Сандер.

Помогите,пж с Python! Напишите программу, которая находит рекордное количество вхождений (не

обязательно подряд) символа в строку. Формат ввода Вводится одна строка. Формат вывода Выводится одно целое число — максимальное количество раз, которое встречается какая-либо буква (без учёта регистра) или иной символ во введённой строке. Пример Ввод: Длинношеееед Вывод: 4
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Горборуков Никита.
S = input("Bвeдитe строку:\n")
s = s.upper()
k = 0
for i in range(0,len(s)):
    if s.count(s[i])>k: k = s.count(s[i])
print(k)

Пример:
Длинношеееддд
4
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Python, которая найдет рекордное количество вхождений символа в строку. Вот пример программы:

```python def find_max_occurrences(string): # Создаем словарь для подсчета количества вхождений каждого символа occurrences = {} # Приводим строку к нижнему регистру для игнорирования регистра символов string = string.lower() # Проходимся по каждому символу в строке for char in string: # Проверяем, является ли символ буквой или другим символом if char.isalpha(): # Если символ уже есть в словаре, увеличиваем его счетчик на 1 if char in occurrences: occurrences[char] += 1 # Если символа нет в словаре, добавляем его и устанавливаем счетчик в 1 else: occurrences[char] = 1 # Находим максимальное количество вхождений max_occurrences = max(occurrences.values()) return max_occurrences

# Считываем строку от пользователя string = input("Введите строку: ")

# Вызываем функцию для нахождения максимального количества вхождений max_occurrences = find_max_occurrences(string)

# Выводим результат print("Максимальное количество вхождений:", max_occurrences) ```

Теперь вы можете ввести строку и программа найдет рекордное количество вхождений символа в эту строку. Например, если вы введете "Длинношеееед", программа выведет "4", так как символ "е" встречается 4 раза.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос