Напишите программу в Паскаль чтобы нарисован был светофор)) небольшой, разрисован нужными цветами(
жёлтый, зелёный, красный) и сам светофор серый..Помогите пожалуйста...ставлю спасибо))) надеюсь на вашу помощь)))( программу не большую)Ответы на вопрос
begin
setwindowsize (600, 600);
setpencolor (clblack);
setbrushcolor (clgray);
rectangle (90, 90, 210, 450 );
setpencolor (clred);
setbrushcolor (clred);
circle (150, 150, 50);
setpencolor (clyellow);
setbrushcolor (clyellow);
circle (150, 260, 50);
setpencolor (clgreen);
setbrushcolor (clgreen);
circle (150, 370, 50);
setpencolor (clblack);
setbrushcolor (clgray);
rectangle (140, 450, 160, 600)
end.
Конечно, я могу помочь вам с этим! Вот пример программы на языке Паскаль, которая рисует светофор:
```pascal program TrafficLight;
uses crt;
const Yellow = 14; Green = 10; Red = 12; Gray = 7;
procedure DrawTrafficLight; begin // Рисуем столб светофора textcolor(Gray); writeln(' '); writeln(' '); writeln(' '); textcolor(White); writeln(' '); writeln(' '); writeln(' ');
// Рисуем круги разных цветов textcolor(Red); writeln(' '); textcolor(Gray); writeln(' '); textcolor(Green); writeln(' '); textcolor(Gray); writeln(' '); textcolor(Yellow); writeln(' '); textcolor(Gray); writeln(' '); end;
begin clrscr; DrawTrafficLight; readln; end. ```
Скопируйте этот код в вашу среду разработки на Паскале и запустите программу. Она должна нарисовать светофор с соответствующими цветами. Надеюсь, это поможет вам!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
