
Задача на паскале: посчитать кол-во пробелов в тексте.


Ответы на вопрос

i,b:integer;
begin
read(a);
b:=0;
for i:=1 to length(a) do
if a[i]=' ' then b+=1;
writeln(b);
end.



Для решения данной задачи на Pascal можно написать программу, которая будет считать количество пробелов в заданном тексте.
Пример программы на Pascal:
```pascal program CountSpaces; var text: string; count, i: integer; begin count := 0; writeln('Введите текст:'); readln(text); for i := 1 to length(text) do begin if text[i] = ' ' then count := count + 1; end; writeln('Количество пробелов в тексте: ', count); end. ```
Эта программа сначала запрашивает у пользователя ввести текст. Затем она проходит по каждому символу в тексте и, если символ является пробелом, увеличивает счетчик на 1. По завершении программы выводится количество пробелов в тексте.
Таким образом, данная программа на Pascal позволяет решить задачу подсчета количества пробелов в тексте.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili