Вопрос задан 28.04.2019 в 09:27. Предмет Информатика. Спрашивает Скарюпин Эдуард.

Составить программу для нахождения суммы десяти произвольных чисел на языке паскаль?

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пенской Дима.

uses crt;
var a,s:real; i:integer;
begin
  clrscr;
  randomize;
  s:=0;
  for i:=1 to 10 do
  begin
    a:=random(100)-50;
    s:=s+a;
    write(a,' ');
  end;
  writeln;
  write('summa=',s);
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Паскаль для нахождения суммы десяти произвольных чисел

Вот пример программы на языке Паскаль, которая находит сумму десяти произвольных чисел:

```pascal program SumOfTenNumbers; var i, number, sum: integer; begin sum := 0; for i := 1 to 10 do begin writeln('Введите число ', i, ': '); readln(number); sum := sum + number; end; writeln('Сумма десяти чисел: ', sum); end. ```

В этой программе используется цикл `for`, который выполняется 10 раз. На каждой итерации пользователю предлагается ввести число, которое затем добавляется к переменной `sum`. В конце программы выводится сумма всех введенных чисел.

Примечание: Приведенный выше код является примером и может быть изменен или дополнен в зависимости от конкретных требований задачи.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос