Вопрос задан 12.05.2018 в 22:46.
Предмет Информатика.
Спрашивает Орлов Дмитрий.
Нужно написать 2 программы желательно в PASCAL ABCПрограмма 2. Пользователь вводит две целые
переменные a, b. Написать программу для выполнения следующих операций:1 вычислить результат целочисленного деления a на b;2 вычислить результат деления a на b;3 вычислить результат деления a на b, вывести его дробную часть;4 вычислить результат деления a на b, вывести его целую часть;5 вычислить результат деления a на b, округлить его.Программа 3. Предложите пользователю ввести трехзначное число, сохраните это число в одну целочисленную переменную, переверните цифры в этом числе.Ответы на вопрос
Отвечает Медведев Артём.
1 задание.
uses crt;
var
a, b : real;
begin
readln (a, b);
writeln (a/b);
writeln (frac(a/b));
writeln (int(a/b));
writeln (round(a/b));
readkey;
end.
2 задание.
uses crt;
var
a: integer;
st, st1, st2, st3: string;
begin
readln (a);
str (a, st);
st1:=st[3];
st2:= st[2];
st3:= st[1];
st:= st1+st2+st3;
writeln (st);
readkey;
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
