
помогите написать программу в паскале с помощью оператора выбора(case.. of.. else) :Напишите
программу для вычисления степени введённого с клавиатуры числа. Степень в диапазоне 0 .. 9.p.s: я начинающий в программировании, поэтому прошу попонятней написать.

Ответы на вопрос

var a,b,c:integer;
begin
writeln('введите число и степень'); {здесь прост программа тебя спрашивает какие числа}
read(a,b); {здесь программа читает их}
case b of {тут выполняется условие типа если b .... и идут сами степени}
0: writeln(1);
1: writeln(a); {здесь что программа выдаст если ты напишешь такую степень}
2: writeln (a*a);
3: writeln (a*a*a);
4: writeln (a*a*a*a);
5: writeln (a*a*a*a*a);
6: writeln (a*a*a*a*a*a);
7: writeln (a*a*a*a*a*a*a);
8: writeln (a*a*a*a*a*a*a*a);
9: writeln (a*a*a*a*a*a*a*a*a);
end;
end.



Конечно, я могу помочь написать программу на Паскале для вычисления степени введенного с клавиатуры числа. Вот пример программы:
```pascal program PowerCalculator;
var base, exponent, result: Integer;
begin writeln('Введите основание: '); readln(base); writeln('Введите степень (от 0 до 9): '); readln(exponent); case exponent of 0: result := 1; 1: result := base; 2: result := base * base; 3: result := base * base * base; 4: result := base * base * base * base; 5: result := base * base * base * base * base; 6: result := base * base * base * base * base * base; 7: result := base * base * base * base * base * base * base; 8: result := base * base * base * base * base * base * base * base; 9: result := base * base * base * base * base * base * base * base * base; else writeln('Степень должна быть от 0 до 9'); result := 0; end; writeln('Результат: ', result); end. ```
В этой программе мы сначала запрашиваем у пользователя основание и степень. Затем мы используем оператор выбора case..of..else, чтобы вычислить значение степени в зависимости от введенной пользователем степени. Если введенная степень не находится в диапазоне от 0 до 9, мы выводим сообщение об ошибке.
Надеюсь, это поможет вам понять, как написать программу на Паскале для вычисления степени числа. Если у вас есть еще вопросы, не стесняйтесь спрашивать!


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili