Вопрос задан 28.04.2019 в 00:54. Предмет Информатика. Спрашивает Сибирина Анастасия.

Очень надо!! пожалуйста)Составить программу на языке Pascal, которая позволяет ввести с клавиатуры

целое трехзначное число, проверяет, симметрично ли оно, и печатает сообщение на экране. (Трёхзначное число симметрично, если крайние цифры числа одинаковые)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пипенко Дарина.

Program task_1;
var
A, B, C : integer;
begin
read(A);
B := A;
C := 0;
While B <> 0 do
begin
C := C*10 + B mod 10;
B := B div 10
end;
If A=C then
begin
writeln('Число симметрично')
end
else
begin
writeln('Число НЕ симметрично')
end;
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Pascal, которая позволяет ввести с клавиатуры целое трехзначное число, проверяет, симметрично ли оно, и печатает сообщение на экране, может выглядеть следующим образом:

```pascal program SymmetricNumber;

var number, firstDigit, lastDigit: integer;

begin writeln('Введите трехзначное число: '); readln(number);

if (number < 100) or (number > 999) then writeln('Ошибка! Введенное число не является трехзначным') else begin firstDigit := number div 100; lastDigit := number mod 10;

if firstDigit = lastDigit then writeln('Введенное число является симметричным') else writeln('Введенное число не является симметричным'); end; end. ```

Эта программа сначала запрашивает у пользователя ввести трехзначное число. Затем она проверяет, является ли введенное число трехзначным, и если нет, выводит сообщение об ошибке. Если число трехзначное, программа определяет первую и последнюю цифры числа, и затем сравнивает их. Если первая и последняя цифры равны, программа выводит сообщение о том, что число является симметричным, в противном случае выводится сообщение о том, что число не является симметричным.

0 0

Последние заданные вопросы в категории Информатика

Задать вопрос