Вопрос задан 27.04.2019 в 21:11. Предмет Информатика. Спрашивает Зориков Ваня.

СРОЧНО!!! ПРОГРАММА С ВЕТВЛЕНИЕМ!!! Составьте программу, которая по введенному вами k-число грибов,

печатает фразу: "Мы нашли в лесу k грибов" причем согласовывает окончание слова «гриб» с k.!!!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Комкова Настя.

var

  count:integer;

begin

  write('Введите количество грибов '); readln(count);

  write('Мы нашли в лесу ', count);

  case count div 10 of

    1: writeln(' грибов');

    else

      case count mod 10 of

        0, 5..9: writeln(' грибов');

        1: writeln(' гриб');

        2..4: writeln(' гриба');

      end;

  end;

end.

0 0
Отвечает Елисеева Яна.

var k:integer;
begin
writeln('Input number of mushrooms: ');
Readln(k);
if k=1 then Writeln('Mi nashli ',k,' grib')

else
if (k=2) or (k=3) or (k=4) then Writeln('Mi nashli ',k,' griba')

else
Writeln('Mi nashli ',k,' gribov');
readln;
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа с ветвлением на Python:

```python k = int(input("Введите количество грибов: "))

if k % 10 == 1 and k % 100 != 11: print(f"Мы нашли в лесу {k} гриб") elif 2 <= k % 10 <= 4 and (k % 100 < 10 or k % 100 >= 20): print(f"Мы нашли в лесу {k} гриба") else: print(f"Мы нашли в лесу {k} грибов") ```

Эта программа сначала запрашивает у пользователя количество грибов (k), затем проверяет остаток от деления k на 10 и 100, чтобы согласовать окончание слова "гриб" с числом k. В зависимости от остатка от деления программа печатает соответствующую фразу.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос