PascalABS составить программу которая определяет 1) является ли число положительным или
отрицательным. 2) считает числа отрицательные и положительные. 3) считает сумму отрицательных и положительныхОтветы на вопрос
begin
for i:=1 to 3 do begin
readln(a);
if a>0 then begin
writeln('Число ',a,' положительное');
k1:=k1+1; s1:=s1+a;
end else if a<0 then begin
writeln('Число ',a,' отрицательное');
k2:=k2+1; s2:=s2+a;
end;
end;
writeln('Количество положительных = ',k1,', их сумма = ',s1);
writeln('Количество отрицательных = ',k2,', их сумма = ',s2);
end.
Пример:
15
Число 15 положительное
-74
Число -74 отрицательное
28
Число 28 положительное
Количество положительных = 2, их сумма = 43
Количество отрицательных = 1, их сумма = -74
Конечно, вот пример программы на PascalABS, которая выполняет все требуемые действия:
```pascal program PositiveNegativeSum;
var num, positiveSum, negativeSum: integer;
begin positiveSum := 0; negativeSum := 0; writeln('Введите число (для завершения введите 0): '); readln(num); while num <> 0 do begin if num > 0 then begin writeln(num, ' - положительное число'); positiveSum := positiveSum + num; end else begin writeln(num, ' - отрицательное число'); negativeSum := negativeSum + num; end; writeln('Введите число (для завершения введите 0): '); readln(num); end; writeln('Сумма положительных чисел: ', positiveSum); writeln('Сумма отрицательных чисел: ', negativeSum); end. ```
Эта программа запрашивает у пользователя числа, определяет их знак (положительное или отрицательное) и считает их сумму соответственно. Программа завершается, когда пользователь вводит 0.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
