Вопрос задан 27.04.2019 в 11:20. Предмет Информатика. Спрашивает Ефименко Евгений.

Составьте программу для вычисления суммы чисел кратных 8 вдиапазоне от а до b. Java

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Макарова Валентина.
Import java.util.Scanner;

class Strange
{
    public static void main (String[] args)
    {
        Scanner sc = new Scanner(System.in);
        int a = sc.nextInt();
        int b = sc.nextInt();
        sc.close();
        int r = a % 8;
        if (r != 0) a += 8 - r;
        int s = 0;
        for (int i=a; i <= b; i+=8) s += i;
        System.out.println("Сумма:" + s);
    }
}
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам с вашим запросом. Вот программа на Java, которая вычисляет сумму чисел, кратных 8, в диапазоне от a до b:

```java public class SumOfMultiplesOfEight {

public static void main(String[] args) { // Задаем значения a и b int a = 10; int b = 100; // Вызываем метод, который возвращает сумму чисел, кратных 8, в диапазоне от a до b int sum = sumOfMultiplesOfEight(a, b); // Выводим результат на экран System.out.println("Сумма чисел, кратных 8, в диапазоне от " + a + " до " + b + " равна " + sum); } // Метод, который возвращает сумму чисел, кратных 8, в диапазоне от a до b public static int sumOfMultiplesOfEight(int a, int b) { // Инициализируем переменную для хранения суммы int sum = 0; // Перебираем все числа в диапазоне от a до b for (int i = a; i <= b; i++) { // Проверяем, является ли число кратным 8 if (i % 8 == 0) { // Добавляем число к сумме sum += i; } } // Возвращаем сумму return sum; } } ```

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос