Вопрос задан 27.04.2019 в 06:33. Предмет Информатика. Спрашивает Шишкин Роман.

Помогите пожалуйста составить программу паскаль и объясните ее дано четырехзначное число,получить

новое поменяв местами первую и последнюю цифру
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Набиев Азамат.
Program zamena;
var s:string;
     x,y:char;
begin
write('Введите четырехзначное число: ');
readln(s);
x:=s[1]; y:=s[4];
s[1]:=y; s[4]:=x;
writeln('Полученное число: ',s);
end.

Считываем число как строку. Символьной переменной "X" присваиваем значение первого символа строки (первой цифры числа). Символьной переменной "Y" присваиваем значение четвертого символа строки (четвертой цифры числа). Делаем обмен первой и четвертой цифры числа: присваиваем первому символу значение переменной "Y", а четвертому символу - значение переменной "X". Выводим получившуюся строку (число) на экран.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Составление программы на Pascal для обмена первой и последней цифры четырехзначного числа

Для начала, вот пример программы на Pascal, которая выполняет задачу обмена первой и последней цифры четырехзначного числа:

```pascal program SwapFirstAndLastDigit;

var number, firstDigit, lastDigit, newNumber: integer;

begin // Ввод четырехзначного числа write('Введите четырехзначное число: '); readln(number);

// Вычисление первой и последней цифры lastDigit := number mod 10; firstDigit := number div 1000;

// Формирование нового числа с поменяными первой и последней цифрами newNumber := lastDigit * 1000 + (number mod 1000) div 10 * 10 + firstDigit;

// Вывод нового числа writeln('Новое число после замены первой и последней цифры: ', newNumber); end. ```

Объяснение программы

1. Ввод числа: - Пользователю предлагается ввести четырехзначное число.

2. Вычисление первой и последней цифры: - Первая цифра вычисляется как результат деления введенного числа на 1000. - Последняя цифра вычисляется как остаток от деления введенного числа на 10.

3. Формирование нового числа: - Новое число формируется путем умножения последней цифры на 1000 (для установки в начало числа), прибавления средних двух цифр (путем взятия остатка от деления на 1000 и деления на 10) и добавления первой цифры.

4. Вывод нового числа: - Новое число выводится на экран.

Эта программа позволяет пользователю ввести четырехзначное число и затем выводит новое число, в котором первая и последняя цифры поменялись местами.

Надеюсь, это объяснение поможет вам понять программу на Pascal для выполнения данной задачи!

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос