Вопрос задан 27.04.2019 в 00:57.
Предмет Информатика.
Спрашивает Огнивова Валерия.
Составить программу которая считает сумму первых n - четных натуральных чисел. Паскаль.Срочно .Даю
50 балловОтветы на вопрос
Отвечает Алимов Елхан.
// PascalABC.NET 3.1, сборка 1195 от 09.03.2016
begin
var n:=ReadInteger('n=');
Writeln('Сумма ',Range(2,2*n,2).Sum)
end.
Тестовое решение:
n= 10
Сумма 110
begin
var n:=ReadInteger('n=');
Writeln('Сумма ',Range(2,2*n,2).Sum)
end.
Тестовое решение:
n= 10
Сумма 110
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на Pascal для подсчета суммы первых n четных натуральных чисел:
```pascal program SumOfFirstNEvenNumbers;
var n, i, sum: integer;
begin sum := 0;
writeln('Введите количество первых четных чисел:'); readln(n);
for i := 1 to n do begin sum := sum + (i * 2); end;
writeln('Сумма первых ', n, ' четных чисел равна: ', sum); end. ```
Эта программа сначала запрашивает у пользователя количество первых четных чисел (n), затем использует цикл для нахождения их суммы. Каждое четное число представлено как удвоенное значение переменной i. Наконец, программа выводит сумму на экран.
Надеюсь, это поможет вам!
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 44
Информатика 23
Информатика 43
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
