16. Составить программу для вывода двух массивов, первый из которых состоит из отрицательных
элементов и задаётся вручную, второй- состоит из нечётных элементов и задаётся функцией случайного выбора.20)Составить массив из 10 отрицательных чисел. Вывести второй массив, состоящий из элементов певого массива, умноженных на введенное число.Все в ТуброПаскале:)Ответы на вопрос
1)
var
a,b:array [1..10] of integer;
i:integer;
begin
for i:=1 to 10 do begin
repeat
write ('A[',i,'] = ');readln(a[i]);
if a[i]>0 then writeln ('Error!');
until a[i]<0;
end;
writeln ('First massiv: ');
for i:=1 to 10 do write (a[i]:4);
writeln;
writeln ('Second massiv: ');
i:=1;
repeat
b[i]:=random(38)+3;
if odd(b[i])=true then i:=i+1;
until i>10;
for i:=1 to 10 do write (b[i]:4);
writeln;
readln;
end.
2)
var
a,b:array [1..10] of integer;
i,k:integer;
begin
randomize;
for i:=1 to 10 do begin
a[i]:=random(15)-15;
write (a[i]:4);
end;
writeln;
write ('Number: ');readln(k);
for i:=1 to 10 do begin
b[i]:=a[i]*k;
write (b[i]:4);
end;
writeln;
readln;
end.
Программа для вывода двух массивов в Turbo Pascal
Для начала, давайте создадим программу для вывода двух массивов в Turbo Pascal.
```pascal program ArrayOutput;
const SIZE = 10;
type NegativeArray = array[1..SIZE] of Integer; OddArray = array[1..SIZE] of Integer;
var negArr: NegativeArray; oddArr: OddArray; i, multiplier: Integer;
begin // Ввод отрицательных чисел в первый массив writeln('Введите 10 отрицательных чисел:'); for i := 1 to SIZE do begin readln(negArr[i]); end;
// Заполнение второго массива случайными нечётными числами Randomize; for i := 1 to SIZE do begin repeat oddArr[i] := Random(100) * 2 + 1; // Генерация случайного нечётного числа until oddArr[i] mod 2 = 1; end;
// Вывод первого массива writeln('Первый массив (отрицательные числа):'); for i := 1 to SIZE do begin write(negArr[i], ' '); end;
// Вывод второго массива writeln; writeln('Второй массив (нечётные числа):'); for i := 1 to SIZE do begin write(oddArr[i], ' '); end;
// Умножение элементов второго массива на введенное число writeln; writeln('Введите число для умножения элементов второго массива:'); readln(multiplier); writeln('Второй массив после умножения на ', multiplier, ':'); for i := 1 to SIZE do begin write(oddArr[i] * multiplier, ' '); end;
end. ```
Эта программа позволяет пользователю ввести 10 отрицательных чисел в первый массив и затем выводит второй массив, состоящий из случайных нечётных чисел. После этого программа запрашивает число для умножения элементов второго массива и выводит результат умножения.
Пример работы программы:
``` Введите 10 отрицательных чисел: -1 -2 -3 -4 -5 -6 -7 -8 -9 -10 Первый массив (отрицательные числа): -1 -2 -3 -4 -5 -6 -7 -8 -9 -10 Второй массив (нечётные числа): 73 11 93 59 79 29 95 57 79 95 Введите число для умножения элементов второго массива: 3 Второй массив после умножения на 3: 219 33 279 177 237 87 285 171 237 285 ```Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
