Вопрос задан 21.04.2019 в 14:57.
Предмет Информатика.
Спрашивает Кирилюк Іра.
Язык Borland C++ никаких паскалей Написать программу,позволяющую для заданного одномерного массива
А из n вещественных или целых элементов реализовать обработку массива.Длина массива N задается пользователем как константное выражение.Исходные данные задать вручную или с помощью генератора случайных чисел,учитывая формат элементов массива А.Тип результата определяется из контекста. -Вычислить количество отрицательных элементов массива; -сумму модулей элементов массива,расположенных после максимального элементаОтветы на вопрос
Отвечает Пантелеева Настя.
#include <cstdlib>
#include <iostream>
using namespace std;
int main(int argc, char *argv[])
{int i,k,max,j,n,s;
srand(time(NULL)); k=0; s=0;
cout<<"Введите размерность массива:"<<endl;
cin>>n;
int a[n];
cout<<"Данный массив:"<<endl;
for (i=0;i<=n;i++) {a[i]=rand()%21-10; cout<<a[i]<<" ";}
max=a[0]; j=0;
for (i=0;i<=n;i++) {if (a[i]<0) k=k+1; if (a[i]>max) {max=a[i]; j=i;}}
cout<<"Количество отрицательных элементов - "<<k<<endl;
for (i=j+1;i<=n;i++) s+=abs(a[i]);
cout<<"Сумма модулей элементов массива, расположенных после максимального - "<<s<<endl;
system("PAUSE");
return EXIT_SUCCESS;
}
#include <iostream>
using namespace std;
int main(int argc, char *argv[])
{int i,k,max,j,n,s;
srand(time(NULL)); k=0; s=0;
cout<<"Введите размерность массива:"<<endl;
cin>>n;
int a[n];
cout<<"Данный массив:"<<endl;
for (i=0;i<=n;i++) {a[i]=rand()%21-10; cout<<a[i]<<" ";}
max=a[0]; j=0;
for (i=0;i<=n;i++) {if (a[i]<0) k=k+1; if (a[i]>max) {max=a[i]; j=i;}}
cout<<"Количество отрицательных элементов - "<<k<<endl;
for (i=j+1;i<=n;i++) s+=abs(a[i]);
cout<<"Сумма модулей элементов массива, расположенных после максимального - "<<s<<endl;
system("PAUSE");
return EXIT_SUCCESS;
}
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 95
Информатика 36
Информатика 23
Информатика 36
Информатика 12
Информатика 14
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
