Вопрос задан 17.04.2019 в 15:48.
Предмет Информатика.
Спрашивает Ивахненко Ксения.
Программу,решающую следующую задачу: дано трёхзначное число.Составить программу вывода на экран
числа, полученного перестановкой цифр сотен и десятков.Помогите пожалуйста за 34 балаОтветы на вопрос
Отвечает Дубровина Даша.
Var a,b,c: integer;
Begin
write('Ведите трёхзначное число: ');
readln (a);
b:=a div 100;
c:=a mod 100 div 10;
writeln('Число, полученное перестановкой цифр сотен и десятков: ',c,b)
End.
Var a,b,c,d: integer;
Begin
write('Ведите трёхзначное число: ');
readln (a);
b:=a div 100;
c:=a mod 100 div 10;
d:=a mod 10;
writeln('Число, полученное перестановкой цифр сотен и десятков: ',c,b,d)
End.
(PascalABCNET)
Begin
write('Ведите трёхзначное число: ');
readln (a);
b:=a div 100;
c:=a mod 100 div 10;
writeln('Число, полученное перестановкой цифр сотен и десятков: ',c,b)
End.
Var a,b,c,d: integer;
Begin
write('Ведите трёхзначное число: ');
readln (a);
b:=a div 100;
c:=a mod 100 div 10;
d:=a mod 10;
writeln('Число, полученное перестановкой цифр сотен и десятков: ',c,b,d)
End.
(PascalABCNET)
Отвечает Матвеев Илья.
Написано на языке Python !!!
n = int(input())
e = n%10
d = n//10%10
s = n//100
print(d*100+s*10+e)
n = int(input())
e = n%10
d = n//10%10
s = n//100
print(d*100+s*10+e)
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
