Вопрос задан 16.04.2019 в 18:56.
Предмет Информатика.
Спрашивает Синевич Алина.
Составьте программу для паскаль Сегодня утром жюри решило добавить в вариант олимпиады еще одну,
Очень Легкую Задачу. Ответственный секретарь Оргкомитета напечатал ее условие в одном экземпляре, и теперь ему нужно до начала олимпиады успеть сделать еще N копий. В его распоряжении имеются два ксерокса, один из которых копирует лист за х секунд, а другой – за y. (Разрешается использовать как один ксерокс, так и оба одновременно. Можно копировать не только с оригинала, но и с копии.) Помогите ему выяснить, какое минимальное время для этого потребуется. Входные данные На вход программы поступают три натуральных числа N, x и y, разделенные пробелом (1 ≤ N ≤ 2∙108, 1 ≤ x, y ≤ 10). Выходные данные Выведите одно число – минимальное время в секундах, необходимое для получения N копий. Метрополитен состоит из нескольких линий метро. Все станции метро в городе пронумерованы натуральными числами от 1 до N. На каждой линии расположено несколько станций. Если одна и та же станция расположена сразу на нескольких линиях, то она является станцией пересадки и на этой станции можно пересесть с любой линии, которая через нее проходит, на любую другую (опять же проходящую через нее). Напишите программу, которая по данному вам описанию метрополитена определит, с каким минимальным числом пересадок можно добраться со станции A на станцию B. Если данный метрополитен не соединяет все линии в одну систему, то может так получиться, что со станции A на станцию B добраться невозможно, в этом случае ваша программа должна это определить. Входные данные Сначала вводится число N — количество станций метро в городе (2≤N≤100). Далее следует число M — количество линий метро (1≤M≤20). Далее идет описание M линий. Описание каждой линии состоит из числа Pi — количество станций на этой линии (2≤Pi≤50) и Pi чисел, задающих номера станций, через которые проходит линия (ни через какую станцию линия не проходит дважды). Затем вводятся два различных числа: A — номер начальной станции, и B — номер станции, на которую нам нужно попасть. При этом если через станцию A проходит несколько линий, то мы можем спуститься на любую из них. Так же если через станцию B проходит несколько линий, то нам не важно, по какой линии мы приедем. Выходные данные Выведите минимальное количество пересадок, которое нам понадобится. Если добраться со станции A на станцию B невозможно, программа должна вывести одно число –1 (минус один).Ответы на вопрос
Отвечает Солодовников Егор.
1)
Program kpa6ya;var x,y,N:integer;BEGINwriteln('x=');readln(x);writeln('y=');readln(y);writeln('N=');readln(N);if (N<1) and (N<2*108) then begin writeln('BBeguTe oT 1 go 2*108 4ucJlo N, a He ',N); readln(N); end;writeln(N/(x+y),' - BpeM9');END.
Program kpa6ya;var x,y,N:integer;BEGINwriteln('x=');readln(x);writeln('y=');readln(y);writeln('N=');readln(N);if (N<1) and (N<2*108) then begin writeln('BBeguTe oT 1 go 2*108 4ucJlo N, a He ',N); readln(N); end;writeln(N/(x+y),' - BpeM9');END.
Топ вопросов за вчера в категории Информатика
Информатика 82
Информатика 45
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
