
Вопрос задан 16.04.2019 в 03:39.
Предмет Информатика.
Спрашивает Зверев Димок.
Задача 2. Составьте программу для нахождения количества литров L, которое содержится в X галлонах
(1 галлон = 4,54609 литра). Исходное количество галлонов задается с клавиатуры. Задача 3. Напишите программу вычисления общего члена Bn и суммы Sn первых n членов геометрической прогрессии. Первый член прогрессии b1, знаменатель прогрессии q и число членов задаются с клавиатуры.

Ответы на вопрос

Отвечает Чайченко Евгений.
//PascalABC.NET 3.2 сборка 1318
Const
gal=4,54609;
Var
x:real;
begin
readln(x);
writeln(x*gal);
end.
//2
Var
b1,q:real;
n:integer;
begin
readln(b1,q,n);
if (b1=0) or (q=0) then
begin
writeln('b1=0 or q=0');
exit;
end
else
if q=1 then
begin
writeln('Sum=',b1*n);
writeln('Bn=',b1);
end
else
begin
Writeln('Sum=',b1*(1-power(q,n))/(1-q));
Writeln('Bn=',b1*power(q,n-1));
end;
end.
Const
gal=4,54609;
Var
x:real;
begin
readln(x);
writeln(x*gal);
end.
//2
Var
b1,q:real;
n:integer;
begin
readln(b1,q,n);
if (b1=0) or (q=0) then
begin
writeln('b1=0 or q=0');
exit;
end
else
if q=1 then
begin
writeln('Sum=',b1*n);
writeln('Bn=',b1);
end
else
begin
Writeln('Sum=',b1*(1-power(q,n))/(1-q));
Writeln('Bn=',b1*power(q,n-1));
end;
end.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili