Вопрос задан 06.04.2019 в 02:20.
Предмет Информатика.
Спрашивает Поволоцкий Александр.
Составить программу которая находит количество двузначных чисел фибоначчи которые начиная с
заданного номера n при делении на 5 дают в остатке заданное zОтветы на вопрос
Отвечает Горновова Лиза.
Var a,b,c,n,n2,z:integer;
begin
write('введите номер первого числа n ==> ');
readln(n);
write('введите искомый остаток ==> z ');
readln(z);
b:=0;
n2:=0;
a:=1;
while c<100 do begin
c:=a+b;
b:=a;
a:=c;
n2:=n2+1;
if (n2>=n) and (c mod 5 = z) then writeln('нужное число ==> ',c);
end;
end.
begin
write('введите номер первого числа n ==> ');
readln(n);
write('введите искомый остаток ==> z ');
readln(z);
b:=0;
n2:=0;
a:=1;
while c<100 do begin
c:=a+b;
b:=a;
a:=c;
n2:=n2+1;
if (n2>=n) and (c mod 5 = z) then writeln('нужное число ==> ',c);
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 94
Информатика 36
Информатика 22
Информатика 36
Информатика 12
Информатика 13
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
